Perda da conexão de dados


Já vi diversas pessoas reclamando da perda da conexão de dados após o bloqueio da tela (na verdade é após bloquear e desbloquear). Só para contextualizar melhor o problema, existem diversos aplicativos que podem interferir nisso, como o JuiceDefender e outros que desabilitam a conexão de dados após um intervalo de tempo ou sob certas condições.
Existem algumas maneiras de se resolver isso, embora nenhuma seja perfeita, pois em alguns casos, ela não funciona. O artigo How to Turn Off and Disable Mobile Data Connection (2G/GPRS/Edge/3G) on Android Phone da My Digital Life, mostra 4 maneiras diferentes de se fazer isso. Comigo só o método 3 (Quick Settings to Disable Data Connection)  funcionou, às vezes.

Depois de muitas tentativas, descobri uma maneira mais fácil: tente colocar em modo avião e em seguida tire do modo avião. Para mim funciona perfeitamente - testado com Motorala Defy, Android 2.2.1 Froyo e 2.3.4 Gingerbread. Eis o "tutorial":
1. Entre no modo avião
2. Espere 5 segundos
3. Saia do modo avião
4. Em alguns segundos a conexão é reativada.
Outra opção é instalar o Base Band Switcher. Basta entrar na aba Americas, selecionar sua operadora e reiniciar o celular. Comigo funcionou com a opção TIM e Android 2.3.4 (não testei com o Froyo).

Um esclarecimento: muitas vezes o celular está conectado em 3G e a pessoa não sabe. Por isso montei a tabela abaixo:
2G (GPRS)   - no celular aparece G ou 2G (depende do modelo)
2.5G (EDGE) - no celular aparece E
3G (WCDMA)  - no celular aparece 3G
3.5G (HSDPA)- no celular aparece H ou 3G (depende do modelo)

Comentários

  1. Olha Alexandre...
    Tenho um defy com android 2.3.4
    E ele nao acha conecção 3G apenas EDGE "E"
    O que pode ser?
    Minha operado é Tim... em outros motorola e outros aparelos funciona a 3G....
    Já tentei configurar as apns e nada...

    ResponderExcluir
  2. Olá Diogo, passei pelo mesmo problema que você e consegui resolver instalando o Base Band Switcher (veja no post o link).

    Qualquer dúvida, avise.

    ResponderExcluir
  3. opa... Instalei o Base Band... e funcionou... nossa.. era unica coisa que tava me deixa irritado... nao saia do E hehehe agora até H apareceu.. hehehe UFFAAA!!! hehehe

    ResponderExcluir
  4. ahh... Muito obrigado pela ajuda alexandre

    ResponderExcluir

Postar um comentário

Postagens mais visitadas deste blog

Como aprender a programar

Netflix não mostra ícone de streaming

Google Hacking